Started 8 months agoNovember 27, 2025Lasted about 2 hoursNovember 27, 202511:45 AM1:25 PMUTC
Affected
Merge Queue
Major outage from 11:45 AM to 1:25 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
The merge queue was not fully operational starting at 6:45AM EST, but we have implemented a fix and it seems to be operating normally again. We are monitoring for further issues.